Thứ Ba, ngày 06/12/2016 15:15 PM (GMT+7)
Thứ Tư, ngày 15/04/2015 06:00 AM (GMT+7)

Kaspersky: Mac OS X và iOS dính lỗi bảo mật nghiêm trọng

Người dùng có thể cập nhật thiết bị lên phiên bản Mac OS hay iOS mới nhất để vá lỗi.

   

Các nhà nghiên cứu tại Kaspersky Lab đã tìm ra một lỗi trong Darwin - nền tảng cốt lõi mã nguồn mở mà Apple dùng để phát triển hệ điều hành Mac OS X và cả iOS. Lỗi này được Kaspersky Lab ghi nhận với tên DoS.OSX.Yosemite.ICMP.Error.exploit.

Lỗi nghiêm trọng này có thể làm cho các thiết bị chạy hệ điều hành Mac OS X 10.10 và iOS 8 từ chối dịch vụ kích hoạt từ xa (DoS), dẫn tới phá hủy thiết bị của người dùng và làm ảnh hưởng đến hệ thống mạng mà các thiết bị này đang kết nối.

 kaspersky: mac os x va ios dinh loi bao mat nghiem trong hinh anh 1

Cả Mac OS và iOS đều dính lỗi nguy hiểm này, nhưng đã được khắc phục trên bản cập nhật mới nhất. 

Các nhà nghiên cứu kêu gọi người dùng hãy nâng cấp hệ điều hành cho máy tính Mac lên Mac OS X 10.10.3 và iPhone, iPad lên iOS 8.3 để không còn lỗi này nữa.

Cụ thể, nghiên cứu được Kaspersky Lab thực hiện cho thấy, các thiết bị có vi xử lý 64-bit và chạy hệ điều hành iOS 8 như iPhone 5S, iPhone 6, iPhone 6 Plus, iPad Air, iPad Air 2, iPad mini 2 và iPad mini 3 đều có nguy cơ dính lỗi bảo mật này.

Với tên gọi “Darwin Nuke”, lỗ hổng này có thể bị khai thác khi xử lý gói tin IP có kích thước cụ thể và có kiểu tùy chọn không hợp pháp. Những kẻ tấn công từ xa có thể kích hoạt từ chối dịch vụ (DoS) để tấn công các thiết bị chạy hệ điều hành Mac OS X 10.10 và iOS 8 bằng cách gửi một gói tin có lỗi đến mục tiêu.

Sau khi xử lý gói tin có lỗi này, hệ thống sẽ gặp sự cố. Các nhà nghiên cứu tại Kaspersky Lab cho biết, hệ thống sẽ bị hỏng nếu gói tin IP có những điều kiện sau:

- Kích thước của IP header nên là 60 byte.

- Kích thước của IP payload nên ít hơn hoặc bằng 65 byte.

- Các tùy chọn IP không chính xác (không đúng kích thước tùy chọn, lớp,...)

Ông Anton Ivanov, nhà phân tích các phần mềm độc hại cấp cao tại Kaspersky Lab cho biết: “Nhìn chung, kẻ tấn công rất khó lợi dụng lỗi này vì phải đáp ứng các điều kiện không hề dễ dàng. Nhưng nếu kiên trì, tội phạm trực tuyến vẫn có thể phá hủy thiết bị hay thậm chí gây ảnh hưởng đến mạng nội bộ công ty".

"Cần thiết lập cho thiết bị định tuyến và kích hoạt tường lửa để từ chối các gói tin có kích thước tùy chọn không hợp lý, nhưng chúng tôi cũng đã phát hiện ra sự kết hợp của các tùy chọn IP sai có thể qua mặt được thiết bị định tuyến trên mạng. Chúng tôi khuyên người dùng các thiết bị chạy hệ điều hành Mac OS X 10.10 và iOS 8 hãy nâng cấp lên phiên bản Mac OS X 10.10.3 và iOS 8.3”, ông Ivanov nhấn mạnh.

Theo Ngọc Phạm (Kaspersky)
Xem bình luận

TIN ĐỌC NHIỀU

Chiếc iPhone 8 phiên bản khái niệm này có thiết kế long lanh, tinh...
Sau hơn 2 tháng thu hồi, Samsung đã tìm ra được nguyên nhân của...
Top 10 smartphone chạy Android mạnh nhất chủ yếu đến từ các nhà sản...